Brister i Adobe Flash gör att en angripare kan krasha, och kanske till och med ta över kontrollen över ditt system.

Både Windows, Mac, Linux och Android är drabbade, skriver itwire.

Adobe rekommenderar att uppdatera Flash till 11.4.402.265 på Windows och OS X. Linux-användare ska se till att ha versionen 11.2.202.238. Kör du Anroid 4.x ska du ha version 11.1.115.17 och om du har Android 3.x ska 11.1.111.16 vara senaste version.

Navigerar du nätet med Google Chrome kommer du få uppdateringen per automatik men du kan komma behöva starta om webbläsaren för att fixen ska gälla.

Adobe Flash är inte enda mjukvaran från Adobe som blöder. I förra veckan skrev TechWorld om hur Adobe Acrobat Reader på Linux läcker som ett såll.

Mer information hittar du hos Adobe.