Om du använder Google Charts eller andra av Googles api-bibliotek som en del av din sajt kan det hända att de slutar fungera. Detta orsakas av ett avbrott hos Google som gör att det äldre jsapi-biblioteket slutar fungera och gör att din url returnerar felkod 502, rapporterar Bleeping Computer.

Avbrottet hos Google får den äldre skript-laddaren på https://www.google.com/jsapi att visa ett felmeddelande, vilket gör att biblioteket inte skickas till webbläsaren, vilket i sin tur gör att kod som är beroende av biblioteket inte körs. När det händer får du meddelandet "Failed to load resource: the server responded with a status of 502 jsapi:1” i din konsol i Developer Tools.

Den bra nyheten är att du enkelt kan byta till det nya biblioteks-laddaren genom att byta ut https://www.google.com/jsapi till https://www.gstatic.com/charts/loader.js i din kod. Detta borde få biblioteken att laddas igen.

Google känner till problemet och jobbar på en lösning.

Läs också:
Google får hård kritik för planen att stoppa annonsblockerare i Chrome
Efter devops – dags att lära sig gitops