Säkerhetsforskaren Nico Waisman varnar för en nyupptäckt sårbarhet i Linux, närmare bestämt i drivrutinen RTLWIFI som används för att koppla upp sig mot trådlösa nätverk med hjälp av chipp från Realtek.

Sårbarheten har fått beteckningen CVE-2019-17666 och kan utnyttjas av hackare för att få kontroll över våra datorer, vilket till exempel gör det möjligt att plantera skadlig kod i smyg. Det enda som krävs är att de är tillräckligt nära för att kunna koppla upp sig via wifi, rapporterar Ars Technica.

Lyckligtvis lovar nu Linux-utvecklare att sårbarheten kommer att täppas till inom kort, så förhoppningsvis är det få användare som råkar illa ut i slutändan.

Enligt uppgift kan sårbarheten även drabba Android-enheter som använder sig av chipp från Realtek, men detta har i skrivande stund inte bekräftats.

Läs också:
Skydda din kod – Supply chain-attacker mot öppen källkod ökar
Canonicals Github-repo hackat