Både Google och Intel varnar för en allvarlig sårbarhet i bluetooth som återfinns i alla versioner av Linux-kärnan utom den allra senaste (5.9), rapporterar Arstechnica.

Sårbarheten har fått beteckningen BleedingTooth och återfinns i BlueZ, en stack som bland annat hanterar bluetooth-protokollen i Linux-baserade operativsystem.

Enligt Google-ingenjören Andy Nguyen kan hackare utnyttja BleedingTooth för att aktivera skadlig kod på Linux-baserade enheter i närheten.

I klippet nedan ser vi hur sårbarheten kan användas för att starta ett program på en annan dator:

Intel, som bidragit till utvecklingen av BlueZ, uppmanar å sin sida oroliga användare att uppdatera Linux-kärnan till version 5.9 så snart som möjligt.

I sammanhanget bör det påpekas att det än så länge inte finns några rapporter om att sårbarheten har utnyttjats av hackare.

Läs även: Torvalds släpper stabil Linux 5.9 – ”Inget läskigt här inne”